Support > Source

Compiling the source in Windows

(1/5) > >>

paopao:
Hello everybody,

this is my first post and I'd like some help to compile Script Basic source.

I have generated all the header files (.h) as requested, with headerer.pl.

Now  I would like to try to compile scriba.c and I try using either Dev C++ or Visual C++ 6. I can't find any project file so I simply open scriba.c and I try to compile it.

In Dev C++ I get a lot of unreference messages such as:

  [Linker error] undefined reference to `alloc_InitSegment'
  [Linker error] undefined reference to `alloc_Alloc'

for example.

What can I do to sort it out? Is there someone, who can help me please?

Thanks a lot!
Roberto

support:
Roberto,

Make sure you have Perl installed and run setup.cmd from the source directory in a console window.


John

paopao:
Hallo John,

first thanks for your reply. I still have to introduce myself but currently I am pretty busy with personal things...

About compiling Script Basic, I tried with setup.cmd from Windows XP but I get the following message:

"The jamal module esd.pm is not installed..."

Where can I find jamal and esd.pm? I tried here: http://peter.verhas.com/progs/perl/jamal/ but the download page is unavailable.

Also, please, if I want to compile scriba.c, could you give me a list of all files to be included in the project?

Thanks,
Roberto


--- Quote from: "support" ---Roberto,

Make sure you have Perl installed and run setup.cmd from the source directory in a console window.


John
--- End quote ---

support:
I just put the 2.1 binaries in the "What's New" section to download. I will have the 2.1 source up soon.

John

paopao:
Hi John,

thanks for your replies.

I downloaded the binaries and source code for 2.1.

I have installed jamal.pl, checked the path for the compiler (I currently have free bcc55, vc++ 6 and dev c++) because nmake did not work but when running setup.cmd I still have problems as reported below:

NMAKE : fatal error U1077: 'cl' : return code '0x2'

when using makefile, for every .c file, I also get:

basext.c (just a sample file) : fatal error c1034: stdio.h: no include path set

it looks to me that scriba.exe, sbhttpd.exe, libdscriba.lib and all modules are not created/compiled.

Any advice, help you can offer?

Thanks a lot,
Roberto

Navigation

[0] Message Index

[#] Next page

Go to full version